Upgrading/de

From FUDforum Wiki
Jump to: navigation, search

FUDforum kann auf die nächste stabile Version oder Entwicklerversion einfach aktualisiert werden. Der Upgrade-Assistent kann von der FUDforum-Webseite herunterladen werden.

Contents

Aktualisierungsmöglichkeiten

FUDforum 2.x kann direkt auf Version 3.0 aktualisiert werden (keine Zwischenschritte notwendig). Um auf Version 3.x zu aktualisieren, ist allerdings zunächst eine Aktualisierung auf 3.0 notwendig.

FUDforum 3.x kann direkt auf die aktuelle Version aktualisiert werden.

Aktualisierungsschritte

Dieser Abschnitt beschreibt, wie FUDforum auf eine aktuellere Version aktualisiert werden kann:

Sicherung des Forums erstellen

Es ist wichtig, vor der Aktualisierung immer zunächst eine Sicherung der Datenbanktabellen und Dateien anzulegen. Anwender können manuell eine Sicherung erstellen oder die Funktion von FUDforum zum Erstellen eines Backups im Administratorenmenü benutzen.

Upgrade-Skript herunterladen / erstellen

Das Upgrade-Skript kann von https://sourceforge.net/projects/fudforum/files/ herunterladen werden.

Erweitere den folgenden Abschnitt für Hinweise zur Erstellen eines eigenen Upgrade-Skriptes (nur für fortgeschrittene Anwender).

Ausführen des Upgrade-Skriptes

Da sich nun das Upgrade-Skript auf deinem Server befindet, entpacke es und platziere es im Web-Verzeichnis deines Forums. Es sollte dann mit http://Forenadresse/upgrade.php darauf zugegriffen werden können.

Das Skript wird verschiedene Fortschrittsangaben ausgeben, welche über die aktuelle Aktion des Skriptes informieren. Wenn die Zwischenspeicherung der Ausgabe oder Module wie mod_gzip aktiviert sind, kannst die Ausgabe möglicherweise erst nach Abschluss des Vorgangs sehen.

Wenn das Upgrade-Skript fertig ist, musst du Konsistenzüberprüfung durchführen, um verschiedene Zwischenspeicher neu erstellt und die Konsistenz der Forendaten sicherstellt. Das Upgrade-Skript versucht, automatisch eine Überprüfung durchzuführen, in dem mit JavaScript ein neues Fenster geöffnet wird. Wenn, aus welchen Grund auch immer, dieses Fenster nicht erscheint, klicke auf den entsprechenden Link, um die Überprüfung im aktuellen Fenster auszuführen.

Nach Abschluss der Konsistenzüberprüfung ist der Aktualisierungsvorgang beendet. Es bleibt nur noch, das Skript upgrade.php zu entfernen, welches im ersten Schritt im Web-Verzeichnis des Forums platziert wurde.

Erneute Ausführung des Upgrade-Skriptes

Es ist unproblematisch, das Upgrade-Skriptes erneut auszuführen, wenn beim ersten Mal etwas schief laufen sollte.

Potentielle Probleme:

The upgrade script is missing the data archive and cannot run. Please download it again and retry.
Das Datenarchiv des Upgrade-Skriptes fehlt. Lade es bitte erneut herunter und versuche es erneut.

Lade das Upgrade-Skript erneut herunter.

THIS UPGRADE SCRIPT HAS ALREADY BEEN RUN, IF YOU WISH TO RUN IT AGAIN USE THE FILE MANAGER TO REMOVE THE ".../data/errors/UPGRADE_STATUS" FILE.
Das Upgrade-Skript wurde bereits ausgeführt. Wenn du es erneut ausführen möchtest, lösche die Datei ".../data/errors/UPGRADE_STATUS".

Lösche die genannte Datei und versuche es erneut.

Siehe auch

Languages
Personal tools