FUDforum 2.5.3

From FUDforum Wiki
Jump to: navigation, search

FUDforum 2.5.3 was never officially released. If you run one of the RC releases, please upgrade to FUDforum 3.0.0 ASAP.

RC 1

No information available.

RC 2

This release is a fairly small bug fix release, which does contain several important bug fixes. Hopefully it'll provide itself to be quite stable and the final release will soon follow.

Here are the changes:

  • Fixed zlib check in the installer
  • Fixed typo in installer/upgrade script for version check
  • Make avatar size detection work in system with open_basedir
  • Fixed a bug with avatar deletion
  • Do not compress already compressed file attachments
  • Better .htaccess detection for PHP versions < 4.3
  • A few PostgreSQL related fixes.
  • Fixed various PATH_INFO template bugs.
  • Handle situations during upgrade of PostgreSQL forums when duplicate indexes exist.
  • Updated French & Chinese translations
  • Fixed bug with calculation of user levels
  • Fixed extra space problem in message editor
  • Added Invision Board -> FUDforum conversion script.

RC 3

This is a dual purpose release, it fixes a number of bugs as well as adding some new features to FUDforum. Here is the changelog

Bug Fixes:

  • Fixed a number of E_NOTICE messages.
  • Removed dependency of phpversion() function.
  • Show smiley preview after it is uploaded.
  • When moderator changes login update moderator cache.
  • Make [notag] tag skip URLs
  • Rebuild moderator list after enabling/disabling aliases.
  • Updated Turkish translation.
  • Fixed help confusion on admin control panel.
  • Fixed links to images in private messages.

New Features:

  • Added the ability to block remote linking to file attachments.
  • Added the ability to create personal pspell dictionaries.
  • Allow width of the 'tab' on threaded view to be manipulated via templates.
  • Added topic merging.
  • Show a link to the message being replied to beside the message subject.
FUDforum versions (* = latest stable version; + = release candidate; ? = development version)

1.0.0 | 1.1.0 | 1.1.1 | 1.2.0 | 1.2.1 | 1.2.2 | 1.2.3 | 1.2.4 | 1.2.5 | 1.2.6 | 1.2.7 | 1.2.8
2.0.0 | 2.0.1 | 2.0.2 | 2.1.0 | 2.1.1 | 2.1.2 | 2.1.3 | 2.2.0 | 2.2.1 | 2.2.2 | 2.2.3 | 2.2.4 | 2.2.5 | 2.3.0 | 2.3.1 | 2.3.2 | 2.3.3 | 2.3.4 | 2.3.5 | 2.3.6 | 2.3.7 | 2.3.8 | 2.5.0 | 2.5.1 | 2.5.2 | 2.5.3 | 2.6.0 | 2.6.1 | 2.6.2 | 2.6.3 | 2.6.4 | 2.6.5 | 2.6.6 | 2.6.7 | 2.6.8 | 2.6.9 | 2.6.10 | 2.6.11 | 2.6.12 | 2.6.13 | 2.6.14 | 2.6.15 | 2.7.0 | 2.7.1 | 2.7.2 | 2.7.3 | 2.7.4 | 2.7.5 | 2.7.6 | 2.7.7 | 2.8.0 | 2.8.1
3.0.0 | 3.0.1 | 3.0.2 | 3.0.3 | 3.0.4 | 3.0.5 | 3.0.6 | 3.0.7 (*) | 3.1.0 (?)

Languages
Personal tools